import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "When: ([\\w]{3}) ([\\w]{3}) ([\\d]{1,2}), ([\\d]{4})";
final String string = "When: Mon Oct 27, 2013 to Fri Nov 1, 2013 \n"
+ "<br />\n\n\n"
+ "<br />Event Status: confirmed</content>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}