import Foundation
let pattern = #"When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}