// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})").unwrap();
let string = "When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}