#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$"
Local $sString = "+89031231232" & @CRLF & _
"92912312-32" & @CRLF & _
"+7929 123 12 32" & @CRLF & _
"+8 929 12-312-32" & @CRLF & _
"+8 929 123-12-32"
Local $sSubst = "+7 (\1) \2\3\4 \5\6 \7\8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)