import Foundation
let pattern = #"^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+89031231232
92912312-32
+7929 123 12 32
+8 929 12-312-32
+8 929 123-12-32
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+7 (\1) \2\3\4 \5\6 \7\8"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)