const regex = /^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0187]?|\\+[87]?)[- .]?(?:(\\([2-9]\\d{2}\\)|[2-9]\\d{2})[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?)$', 'gm')
const str = `+89031231232
92912312-32
+7929 123 12 32
+8 929 12-312-32
+8 929 123-12-32`;
const subst = `+7 (\1) \2\3\4 \5\6 \7\8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);