// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$").unwrap();
let string = "+89031231232
92912312-32
+7929 123 12 32
+8 929 12-312-32
+8 929 123-12-32";
let substitution = "+7 (\\1) \\2\\3\\4 \\5\\6 \\7\\8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}