import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0187]?|\\+[87]?)[- .]?(?:(\\([2-9]\\d{2}\\)|[2-9]\\d{2})[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?[- .]?(\\d)[- .]?)$";
final String string = "+89031231232\n"
+ "92912312-32\n"
+ "+7929 123 12 32\n"
+ "+8 929 12-312-32\n"
+ "+8 929 123-12-32";
final String subst = "+7 (\\1) \\2\\3\\4 \\5\\6 \\7\\8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}