using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0187]?|\+[87]?)[- .]?(?:(\([2-9]\d{2}\)|[2-9]\d{2})[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?[- .]?(\d)[- .]?)$";
string substitution = @"+7 (\1) \2\3\4 \5\6 \7\8";
string input = @"+89031231232
92912312-32
+7929 123 12 32
+8 929 12-312-32
+8 929 123-12-32";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}