#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https:+[\w\d-.\/]+jpg"
Local $sString = "<![CDATA[" & @CRLF & _
"<img referrerpolicy="no-referrer" src="https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg"><br>" & @CRLF & _
"]]>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")