using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:+[\w\d-.\/]+jpg";
string input = @"<![CDATA[
<img referrerpolicy=""no-referrer"" src=""https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg""><br>
]]>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}