re = /https:+[\w\d-.\/]+jpg/
str = '<![CDATA[
<img referrerpolicy="no-referrer" src="https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg"><br>
]]>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end