package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:+[\w\d-.\/]+jpg`)
var str = `<![CDATA[
<img referrerpolicy="no-referrer" src="https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg"><br>
]]>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}