const regex = /https:+[\w\d-.\/]+jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:+[\\w\\d-.\\\/]+jpg', 'g')
const str = `<![CDATA[
<img referrerpolicy="no-referrer" src="https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg"><br>
]]>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}