// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https:+[\w\d-.\/]+jpg").unwrap();
let string = "<![CDATA[
<img referrerpolicy=\"no-referrer\" src=\"https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg\"><br>
]]>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}