# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https:+[\w\d-.\/]+jpg"
test_str = ("<![CDATA[\n"
"<img referrerpolicy=\"no-referrer\" src=\"https://scontent-sjc3-1.cdninstagram.com/vp/3ae37927158eaae1bb9d4fe0752aa85f/5C1F0F58/t51.2885-15/e35/38261725_382280748969632_602638638102085632_n.jpg\"><br>\n"
"]]>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.