#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$"
Local $sString = "+7(985)392-75-73(1152)" & @CRLF & _
"+7(985)392-75-73 доб.1152" & @CRLF & _
"+7(985)392-75-73 доб. 78135" & @CRLF & _
"+7(985)392-75-73 11522" & @CRLF & _
"+7(985)392-75-73" & @CRLF & _
"+7(985)392-75-73"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")