import re
regex = re.compile(r"(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$", flags=re.DOTALL | re.MULTILINE)
test_str = ("+7(985)392-75-73(1152)\n"
"+7(985)392-75-73 доб.1152\n"
"+7(985)392-75-73 доб. 78135\n"
"+7(985)392-75-73 11522\n"
"+7(985)392-75-73\n"
"+7(985)392-75-73")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")