re = /(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$/m
str = '+7(985)392-75-73(1152)
+7(985)392-75-73 доб.1152
+7(985)392-75-73 доб. 78135
+7(985)392-75-73 11522
+7(985)392-75-73
+7(985)392-75-73'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end