const regex = /(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$/sgm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:8|\\+7|7)?[-\\s\\(]*(?<kod>\\d{3,4})?[-\\s\\)]*(?<phone>[\\d-]{7,10})(?:[\\D]+(?<dob>\\d+))?\\D*$', 'sgm')
const str = `+7(985)392-75-73(1152)
+7(985)392-75-73 доб.1152
+7(985)392-75-73 доб. 78135
+7(985)392-75-73 11522
+7(985)392-75-73
+7(985)392-75-73`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}