import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:8|\\+7|7)?[-\\s\\(]*(?<kod>\\d{3,4})?[-\\s\\)]*(?<phone>[\\d-]{7,10})(?:[\\D]+(?<dob>\\d+))?\\D*$";
final String string = "+7(985)392-75-73(1152)\n"
+ "+7(985)392-75-73 доб.1152\n"
+ "+7(985)392-75-73 доб. 78135\n"
+ "+7(985)392-75-73 11522\n"
+ "+7(985)392-75-73\n"
+ "+7(985)392-75-73";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}