use strict;
my $str = '+7(985)392-75-73(1152)
+7(985)392-75-73 доб.1152
+7(985)392-75-73 доб. 78135
+7(985)392-75-73 11522
+7(985)392-75-73
+7(985)392-75-73';
my $regex = qr/(?:8|\+7|7)?[-\s\(]*(?<kod>\d{3,4})?[-\s\)]*(?<phone>[\d-]{7,10})(?:[\D]+(?<dob>\d+))?\D*$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}