#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)\[if \s+ [^]]* ]" & @CRLF & _
"" & @CRLF & _
"(?<content> [^[]*+ (?> (?R) [^[]* )*+ )" & @CRLF & _
"(?: \[elseif \s+ [^]]* ] \g<content> )*+" & @CRLF & _
"(?: \[else] \g<content> )?+" & @CRLF & _
"" & @CRLF & _
"\[/if]"
Local $sString = "$string = '" & @CRLF & _
" [if true]" & @CRLF & _
" [if true]" & @CRLF & _
" [if false]" & @CRLF & _
" [else]" & @CRLF & _
" [/if]" & @CRLF & _
" [elseif false]" & @CRLF & _
" [if true]" & @CRLF & _
" [/if]" & @CRLF & _
" [else]" & @CRLF & _
" [/if]" & @CRLF & _
" [elseif false]" & @CRLF & _
" [/if]" & @CRLF & _
" [if false]" & @CRLF & _
" [if false]" & @CRLF & _
" [else]" & @CRLF & _
" [/if]" & @CRLF & _
" [else]" & @CRLF & _
" [if true]" & @CRLF & _
" [/if]" & @CRLF & _
" [/if]" & @CRLF & _
"';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")