import re
regex = re.compile(r"""
\[if \s+ [^]]* ]
(?<content> [^[]*+ (?> (?R) [^[]* )*+ )
(?: \[elseif \s+ [^]]* ] \g<content> )*+
(?: \[else] \g<content> )?+
\[/if]
""", flags=re.VERBOSE)
test_str = ("$string = '\n"
" [if true]\n"
" [if true]\n"
" [if false]\n"
" [else]\n"
" [/if]\n"
" [elseif false]\n"
" [if true]\n"
" [/if]\n"
" [else]\n"
" [/if]\n"
" [elseif false]\n"
" [/if]\n"
" [if false]\n"
" [if false]\n"
" [else]\n"
" [/if]\n"
" [else]\n"
" [if true]\n"
" [/if]\n"
" [/if]\n"
"';")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")