// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\[if \s+ [^]]* ]
(?<content> [^[]*+ (?> (?R) [^[]* )*+ )
(?: \[elseif \s+ [^]]* ] \g<content> )*+
(?: \[else] \g<content> )?+
\[/if]").unwrap();
let string = "$string = '
[if true]
[if true]
[if false]
[else]
[/if]
[elseif false]
[if true]
[/if]
[else]
[/if]
[elseif false]
[/if]
[if false]
[if false]
[else]
[/if]
[else]
[if true]
[/if]
[/if]
';";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}