import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[if \\s+ [^]]* ]\n\n"
+ "(?<content> [^[]*+ (?> (?R) [^[]* )*+ )\n"
+ "(?: \\[elseif \\s+ [^]]* ] \\g<content> )*+\n"
+ "(?: \\[else] \\g<content> )?+\n\n"
+ "\\[/if]";
final String string = "$string = '\n"
+ " [if true]\n"
+ " [if true]\n"
+ " [if false]\n"
+ " [else]\n"
+ " [/if]\n"
+ " [elseif false]\n"
+ " [if true]\n"
+ " [/if]\n"
+ " [else]\n"
+ " [/if]\n"
+ " [elseif false]\n"
+ " [/if]\n"
+ " [if false]\n"
+ " [if false]\n"
+ " [else]\n"
+ " [/if]\n"
+ " [else]\n"
+ " [if true]\n"
+ " [/if]\n"
+ " [/if]\n"
+ "';";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}