import Foundation
let pattern = #"""
\[if \s+ [^]]* ]
(?<content> [^[]*+ (?> (?R) [^[]* )*+ )
(?: \[elseif \s+ [^]]* ] \g<content> )*+
(?: \[else] \g<content> )?+
\[/if]
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
$string = '
[if true]
[if true]
[if false]
[else]
[/if]
[elseif false]
[if true]
[/if]
[else]
[/if]
[elseif false]
[/if]
[if false]
[if false]
[else]
[/if]
[else]
[if true]
[/if]
[/if]
';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)