re = /\[if \s+ [^]]* ]
(?<content> [^[]*+ (?> (?R) [^[]* )*+ )
(?: \[elseif \s+ [^]]* ] \g<content> )*+
(?: \[else] \g<content> )?+
\[\/if]/x
str = '$string = \'
[if true]
[if true]
[if false]
[else]
[/if]
[elseif false]
[if true]
[/if]
[else]
[/if]
[elseif false]
[/if]
[if false]
[if false]
[else]
[/if]
[else]
[if true]
[/if]
[/if]
\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end