# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(?=[^\[]*\])//g;t' <<< " \"value\": [
0,
38,
255,
255
],
\"comment\": \"bright blue, entrance coupler\",
\"connector\": true,
\"connector-value\": [0, 0, 0, 0]
},
{
\"value\": [
0,
255,
186,
255
],
\"comment\": \"bright aqua, water coupler\",
\"connector\": true,
\"connector-value\": [0, 0, 0, 0]
},
{
\"value\": [
32,
32,
32,
255]"