const regex = new RegExp('\\s(?=[^\\[]*\\])', 'g')
const str = ` "value": [
0,
38,
255,
255
],
"comment": "bright blue, entrance coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
0,
255,
186,
255
],
"comment": "bright aqua, water coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
32,
32,
32,
255]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);