import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(?=[^\\[]*\\])";
final String string = " \"value\": [\n"
+ "0,\n"
+ "38,\n"
+ "255,\n"
+ "255\n"
+ " ],\n"
+ " \"comment\": \"bright blue, entrance coupler\",\n"
+ " \"connector\": true,\n"
+ " \"connector-value\": [0, 0, 0, 0]\n"
+ " },\n"
+ " {\n"
+ " \"value\": [\n"
+ "0,\n"
+ "255,\n"
+ "186,\n"
+ "255\n"
+ " ],\n"
+ " \"comment\": \"bright aqua, water coupler\",\n"
+ " \"connector\": true,\n"
+ " \"connector-value\": [0, 0, 0, 0]\n"
+ " },\n"
+ " {\n"
+ " \"value\": [\n"
+ "32,\n"
+ "32,\n"
+ "32,\n"
+ "255]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}