import re
regex = re.compile(r"\s(?=[^\[]*\])")
test_str = (" \"value\": [\n"
"0,\n"
"38,\n"
"255,\n"
"255\n"
" ],\n"
" \"comment\": \"bright blue, entrance coupler\",\n"
" \"connector\": true,\n"
" \"connector-value\": [0, 0, 0, 0]\n"
" },\n"
" {\n"
" \"value\": [\n"
"0,\n"
"255,\n"
"186,\n"
"255\n"
" ],\n"
" \"comment\": \"bright aqua, water coupler\",\n"
" \"connector\": true,\n"
" \"connector-value\": [0, 0, 0, 0]\n"
" },\n"
" {\n"
" \"value\": [\n"
"32,\n"
"32,\n"
"32,\n"
"255]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)