$re = '/\s(?=[^\[]*\])/';
$str = ' "value": [
0,
38,
255,
255
],
"comment": "bright blue, entrance coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
0,
255,
186,
255
],
"comment": "bright aqua, water coupler",
"connector": true,
"connector-value": [0, 0, 0, 0]
},
{
"value": [
32,
32,
32,
255]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;