#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?=[^\[]*\])"
Local $sString = " "value": [" & @CRLF & _
"0," & @CRLF & _
"38," & @CRLF & _
"255," & @CRLF & _
"255" & @CRLF & _
" ]," & @CRLF & _
" "comment": "bright blue, entrance coupler"," & @CRLF & _
" "connector": true," & @CRLF & _
" "connector-value": [0, 0, 0, 0]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "value": [" & @CRLF & _
"0," & @CRLF & _
"255," & @CRLF & _
"186," & @CRLF & _
"255" & @CRLF & _
" ]," & @CRLF & _
" "comment": "bright aqua, water coupler"," & @CRLF & _
" "connector": true," & @CRLF & _
" "connector-value": [0, 0, 0, 0]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "value": [" & @CRLF & _
"32," & @CRLF & _
"32," & @CRLF & _
"32," & @CRLF & _
"255]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)