# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(define:[^>]+>)(.*?)<\\/\1/\2/gm;t' <<< "text
<define:dos> This string explains DOS.</define:dos>
<define:foo> This string explains Foo.</define:foo>
more text"