use strict;
my $str = 'text
<define:dos> This string explains DOS.</define:dos>
<define:foo> This string explains Foo.</define:foo>
more text';
my $regex = qr/<(define:[^>]+>)(.*?)<\/\1/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";