import Foundation
let pattern = #"<(define:[^>]+>)(.*?)<\/\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
text
<define:dos> This string explains DOS.</define:dos>
<define:foo> This string explains Foo.</define:foo>
more text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)