re = /<(define:[^>]+>)(.*?)<\/\1/m
str = 'text
<define:dos> This string explains DOS.</define:dos>
<define:foo> This string explains Foo.</define:foo>
more text'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result