const regex = /<(define:[^>]+>)(.*?)<\/\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(define:[^>]+>)(.*?)<\\\/\\1', 'gm')
const str = `text
<define:dos> This string explains DOS.</define:dos>
<define:foo> This string explains Foo.</define:foo>
more text`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);