#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<(define:[^>]+>)(.*?)<\/\1"
Local $sString = "text" & @CRLF & _
"<define:dos> This string explains DOS.</define:dos>" & @CRLF & _
"<define:foo> This string explains Foo.</define:foo>" & @CRLF & _
"more text"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)