# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=---\n).*?(?=\n---)/replacement/gms;t' <<< "---
something: test
test: yes
front: matter
---
Test test"