#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?<=---\n).*?(?=\n---)"
Local $sString = "---" & @CRLF & _
"something: test" & @CRLF & _
"test: yes" & @CRLF & _
"front: matter" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"Test test"
Local $sSubst = "replacement"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)