use strict;
my $str = '---
something: test
test: yes
front: matter
---
Test test';
my $regex = qr/(?<=---\n).*?(?=\n---)/msp;
my $subst = 'replacement';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";