import re
regex = re.compile(r"(?<=---\n).*?(?=\n---)", flags=re.MULTILINE | re.DOTALL)
test_str = ("---\n"
"something: test\n"
"test: yes\n"
"front: matter\n"
"---\n\n"
"Test test")
subst = "replacement"
result = regex.sub(subst, test_str)
if result:
print(result)