const regex = /(?<=---\n).*?(?=\n---)/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=---\\n).*?(?=\\n---)', 'gms')
const str = `---
something: test
test: yes
front: matter
---
Test test`;
const subst = `replacement`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);