$re = '/(?<=---\n).*?(?=\n---)/ms';
$str = '---
something: test
test: yes
front: matter
---
Test test';
$subst = "replacement";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;