re = /(?<=---\n).*?(?=\n---)/m
str = '---
something: test
test: yes
front: matter
---
Test test'
subst = 'replacement'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result