#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\*+\s+)(\S+)(.+)"
Local $sString = "*** A.0044806.1 Project 440064" & @CRLF & _
"*** S.0005049.18.1 Funding FY18" & @CRLF & _
"*** S.0061768.04.01.36.01 SPECIAL PROJECT" & @CRLF & _
"*** S.0072385.001 INSTALL VOICE AND DATE EQUIPMENT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")