const regex = /(\*+\s+)(\S+)(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\*+\\s+)(\\S+)(.+)', 'gm')
const str = `*** A.0044806.1 Project 440064
*** S.0005049.18.1 Funding FY18
*** S.0061768.04.01.36.01 SPECIAL PROJECT
*** S.0072385.001 INSTALL VOICE AND DATE EQUIPMENT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}