// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\*+\s+)(\S+)(.+)").unwrap();
let string = "*** A.0044806.1 Project 440064
*** S.0005049.18.1 Funding FY18
*** S.0061768.04.01.36.01 SPECIAL PROJECT
*** S.0072385.001 INSTALL VOICE AND DATE EQUIPMENT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}